Investigating Issue

Incident Report for Campus Labs

Resolved

The issue with Form in Engage was resolved as of approximately 12:30 PM EST and no further incidents have been reported.
Posted May 08, 2025 - 12:54 EDT

Investigating

We are currently investigating an issue with Forms in Engage which prevents Forms featuring Additional Fields from being successfully completed.
Posted May 08, 2025 - 08:55 EDT
This incident affected: Engage (Forms, Elections, and Registrations).