Issue Resolved - Login Issues
Incident Report for Campus Labs
Resolved
The issue with logging into some Anthology products was resolved as of approximately 11:58 AM ET and no further incidents have been reported.
Posted Apr 04, 2024 - 11:37 EDT