Issue Identified
Incident Report for Campus Labs
Resolved
The issue with Course Evaluations has been resolved as of approximately 9:35pm ET and no further incidents have been reported.
Posted Jul 18, 2024 - 21:37 EDT
Identified
Due to a Microsoft Azure incident, some customers may experience an issue accessing their Course Evaluation site. We are monitoring the Microsoft issue.
Posted Jul 18, 2024 - 21:13 EDT
This incident affected: Course Evaluations (Manager Portal, MyCoursEval, Remote Portal, Evaluation Collection (SaaS only), Mailing Service, FTPS).