Investigating Issue - Engage
Incident Report for Campus Labs
Resolved
The issue with accessing Engage was resolved as of September 5, 2024. We have been monitoring and optimizing the situation since, and no further incidents have been reported.
Posted Sep 20, 2024 - 13:55 EDT
Monitoring
We believe the issue with accessing Engage has been addressed. We will continue monitoring and post a final update soon.
Posted Sep 05, 2024 - 09:36 EDT
Update
We are continuing to investigate this issue.
Posted Sep 04, 2024 - 11:16 EDT
Investigating
We are currently investigating an issue with accessing Engage.
Posted Sep 03, 2024 - 14:47 EDT
This incident affected: Engage (Explore web interface, Action Center web interface, Administration web interface, Budgeting web interface).