Site Performance and Navigation Issues

Incident Report for Campus Labs

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 08:14 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 15:25 EDT

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 12:00 EDT

Investigating

We are currently investigating an issue affecting certain administrative functions within Engage. Users may experience errors or be unable to access some administrative pages and workflows. Our team is actively investigating the issue and working to restore full functionality. We will provide updates as more information becomes available.
Posted Jul 23, 2026 - 09:15 EDT
This incident affected: Engage (Explore web interface, Action Center web interface, Administration web interface, Forms, Elections, and Registrations, Budgeting web interface).