Investigating Issue

Incident Report for Campus Labs

Update

We are continuing to investigate this issue.
Posted May 14, 2026 - 13:18 EDT

Investigating

We are currently investigating an issue with site navigation and features in Engage
Posted May 14, 2026 - 11:12 EDT
This incident affects: Engage (Explore web interface, Action Center web interface, Administration web interface, Forms, Elections, and Registrations, Public API).