Investigating Issue - Evaluate
Incident Report for Campus Labs
Resolved
The issue with the Faculty experience in Evaluate was resolved as of approximately {time} and no further incidents have been reported.
Posted Nov 01, 2023 - 13:55 EDT
Investigating
We are currently investigating an issue with the Faculty experience in Evaluate. We will post an update shortly.
Posted Nov 01, 2023 - 12:40 EDT
This incident affected: Evaluate (Faculty Experience).