Investigating Issue - Engage
Incident Report for Campus Labs
Resolved
The issue with creating and editing Events in Engage was resolved as of approximately 9:40am ET and no further incidents have been reported.
Posted Nov 18, 2024 - 09:52 EST
Investigating
We are currently investigating an issue with creating and editing Events in Engage. We will post an update shortly.
Posted Nov 18, 2024 - 08:58 EST
This incident affected: Engage (Action Center web interface).