Investigating Issue - Engage
Incident Report for Campus Labs
Resolved
The issue with accessing Engage was resolved as of approximately 2:14pm ET and no further incidents have been reported.
Posted Sep 05, 2023 - 14:19 EDT
Investigating
We are currently investigating an issue with accessing Engage. We will post an update shortly.
Posted Sep 05, 2023 - 14:03 EDT
This incident affected: Engage (Explore web interface, Action Center web interface, Administration web interface, Forms, Elections, and Registrations, Budgeting web interface, Corq App, Event Check-in App, Public API, Vanity URLs, Mail Relays).