Investigating Issue - Portfolio
Incident Report for Campus Labs
Resolved
The issue that some users may have been experiencing when logging into Portfolio was resolved as of approximately 10:40am ET and no further incidents have been reported.
Posted Feb 12, 2024 - 10:44 EST
Investigating
We are currently investigating an issue with Portfolio. Some users may be experiencing issues logging into their accounts. We will post an update shortly. .
Posted Feb 12, 2024 - 10:33 EST
This incident affected: Portfolio.