Investigating Issue - Course Evaluations with IDEA
Incident Report for Campus Labs
Resolved
The issue with some Faculty being unable to access Course Evaluations with IDEA was resolved as of approximately 12:30pm ET and no further incidents have been reported.
Posted Jun 16, 2023 - 12:35 EDT
Investigating
We are currently investigating an issue where some Faculty are not able to access Course Evaluations with IDEA. We will post an update shortly.
Posted Jun 16, 2023 - 12:34 EDT
This incident affected: Evaluate (Faculty Experience).