Investigating Issue
Incident Report for Campus Labs
Resolved
The issue with mailing was resolved as of approximately 10:00am and no further incidents have been reported.
Posted Oct 15, 2018 - 10:26 EDT
Investigating
We are currently investigating an issue with the delivery of outbound emails sent by or from within Campus Labs products.
Posted Oct 14, 2018 - 20:02 EDT
This incident affected: Core Services (Mailing Service).