Investigating Issue - Corq
Incident Report for Campus Labs
Resolved
The issue with the Corq app has been resolved, and no further incidents have been reported.
Posted Apr 13, 2021 - 12:36 EDT
Investigating
We are currently investigating an issue with the Corq app. We will post an update as more information becomes available.
Posted Apr 13, 2021 - 12:18 EDT
This incident affected: Engage (Corq App).