Course Evaluations Faculty Page Issue
Incident Report for Campus Labs
Resolved
Access to the faculty experience has been restored.
Posted Aug 04, 2022 - 09:34 EDT
Update
We are continuing to investigate this issue.
Posted Aug 03, 2022 - 19:27 EDT
Update
We are currently investigating an access issue for the faculty experience in Course Evaluations with IDEA.
Posted Aug 03, 2022 - 18:58 EDT
Investigating
.
Posted Aug 03, 2022 - 18:21 EDT
This incident affected: Course Evaluations (Faculty Experience).