Investigating issue - Engage (in Canada only)
Incident Report for Campus Labs
Resolved
The issue with accessing Engage in Canada was resolved as of approximately 12:23pm ET and no further incidents have been reported.
Posted May 13, 2023 - 12:31 EDT
Investigating
We are currently investigating an issue with accessing Engage (in Canada only). We will post an update shortly.
Posted May 13, 2023 - 12:07 EDT
This incident affected: Engage (Explore web interface, Action Center web interface, Administration web interface, Forms, Elections, and Registrations, Budgeting web interface, Corq App, Event Check-in App, Public API, Vanity URLs, Mail Relays).