Investigating Issue - Course Evaluation
Incident Report for Campus Labs
Resolved
The issue with Faculty Experience was resolved as of approximately 3pm ET and no further incidents have been reported.
Posted Apr 08, 2019 - 16:28 EDT
Monitoring
We believe the issue with Faculty Experience has been addressed. We will continue monitoring and post a final update soon.
Posted Apr 08, 2019 - 14:57 EDT
Investigating
We are currently investigating site slowness with the Faculty Experience.
Posted Apr 08, 2019 - 12:31 EDT
This incident affected: Evaluate (Faculty Experience).