Investigating Issue - Course Evaluations
Incident Report for Campus Labs
Resolved
The issue with Faculty Experience was resolved as of approximately 2:15pm ETand no further incidents have been reported.
Posted Apr 09, 2019 - 15:24 EDT
Monitoring
We believe the issue with the Faculty Experience has been addressed. We will continue monitoring and post a final update soon.
Posted Apr 09, 2019 - 14:15 EDT
Investigating
We are currently investigating site slowness with the Faculty Experience.
Posted Apr 09, 2019 - 12:07 EDT
This incident affected: Evaluate (Faculty Experience).