Investigating Issue - Engage
Incident Report for Campus Labs
Resolved
The site performance issue in Engage has been resolved and no further incidents have been reported.
Posted Sep 17, 2020 - 12:34 EDT
Investigating
We are currently investigating a site performance issue in Engage. We will post an update as soon as one becomes available.
Posted Sep 17, 2020 - 12:15 EDT
This incident affected: Engage (Explore web interface, Action Center web interface, Administration web interface, Forms, Elections, and Registrations, Budgeting web interface, Corq App, Event Check-in App, Public API, Vanity URLs, Mail Relays).