Investigating Issue
Incident Report for Campus Labs
Resolved
The issue with Engage is resolved at this time and no further incidents have been reported.
Posted Jan 07, 2020 - 16:21 EST
Monitoring
We believe the issue with Engage has been addressed. We will continue monitoring and post a final update soon.
Posted Jan 07, 2020 - 16:14 EST
Investigating
We are currently investigating an issue with Engage. We will post updated as they become available.
Posted Jan 07, 2020 - 16:01 EST
This incident affected: Engage (Explore web interface, Action Center web interface, Administration web interface, Forms, Elections, and Registrations, Budgeting web interface, Corq App, Event Check-in App, Public API, Vanity URLs, Mail Relays).