Investigating Issue
Incident Report for Campus Labs
Resolved
The issue with loading issues in the Faculty Expereince was resolved as of approximately 11:00 am EDT and no further incidents have been reported.
Posted Mar 20, 2017 - 14:06 EDT
Monitoring
We believe the Faculty Experience loading issues have been addressed. We will continue monitoring and post a final update soon.
Posted Mar 20, 2017 - 11:00 EDT
Investigating
We are currently investigating an issue with intermittent loading issues in the Faculty Experience.
Posted Mar 20, 2017 - 10:39 EDT