Engage Site Accessibility
Incident Report for Campus Labs
Resolved
The issue in Engage was resolved as of approximately 4:42pm EDT and no further incidents have been reported.
Posted Jul 20, 2017 - 17:12 EDT
Monitoring
We believe the issue with site accessibility has been addressed. We will continue monitoring and post a final update soon.
Posted Jul 20, 2017 - 16:42 EDT
Investigating
We are currently investigating an issue with site accessibility in Engage.
Posted Jul 20, 2017 - 16:25 EDT