Monitoring Issue
Incident Report for Campus Labs
Resolved
The site performance issue in Engage has now been resolved, and no further incidents have been reported.
Posted Sep 17, 2020 - 12:33 EDT
Monitoring
We believe the site performance issue in Engage has been addressed. We will continue monitoring and post a final update soon.
Posted Sep 17, 2020 - 12:20 EDT
This incident affected: Engage (Explore web interface, Action Center web interface, Administration web interface, Forms, Elections, and Registrations, Budgeting web interface, Corq App, Event Check-in App, Public API, Vanity URLs, Mail Relays).