Course Evaluation Administration Page
Incident Report for Campus Labs
Resolved
The issue with the Administration portal in Course Evaluation was resolved as of approximately 5:07pm EDT and no further incidents have been reported.
Posted Jun 20, 2018 - 09:08 EDT
Monitoring
We believe the issue with the Administration portal in Course Evaluation has been addressed. We will continue monitoring and post a final update soon.
Posted Jun 19, 2018 - 17:23 EDT
Investigating
We are currently investigating an issue with connectivity issues in the administrations’ page in Course Evaluations.
Posted Jun 19, 2018 - 17:08 EDT
This incident affected: Evaluate (Administration Portal).