Investigating Course Evaluations with IDEA Issue
Incident Report for Campus Labs
Resolved
The issue with {issue} in {area/product} was resolved as of approximately {time} and no further incidents have been reported.
Posted Apr 26, 2021 - 13:03 EDT
Investigating
We are currently investigating this issue.
Posted Apr 26, 2021 - 12:21 EDT
This incident affected: Course Evaluations (Evaluation Collection, Faculty Experience, Administration Portal).