Landing Page Issue

Incident Report for Campus Labs

Resolved

The issue has been resolved.
Posted Aug 03, 2022 - 18:39 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 03, 2022 - 18:20 EDT

Investigating

We are currently investigating an issue with our landing page. Products are still accessible by going directly to the product URL.
Posted Aug 03, 2022 - 17:52 EDT
This incident affected: Landing Page.