Investigating Issue - Engage Vanity URLs
Incident Report for Campus Labs
Resolved
The issue with vanity URLs in Engage (US) is now resolved.
Posted Jul 09, 2020 - 15:09 EDT
Investigating
We are currently investigating an issue with vanity URLs in Engage (US). We will post an update as more information becomes available.
Posted Jul 09, 2020 - 14:49 EDT
This incident affected: Engage (Vanity URLs).