Investigating Issue
Incident Report for Campus Labs
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 17:57 EST
Update
We are continuing to investigate this issue.
Posted Nov 09, 2020 - 10:12 EST
Investigating
We are investigating an issue with our notation mailing service at this time where notification emails are not being sent. We will provide updates shortly.
Posted Nov 09, 2020 - 10:03 EST
This incident affected: Beacon (Mailing system).