Investigating Issue - Chalk & Wire
Incident Report for Campus Labs
Resolved
The issue with logging in to Chalk & Wire was resolved has been resolved, and no further incidents have been reported.
Posted Sep 03, 2020 - 13:33 EDT
Investigating
We are currently investigating an issue with logging in to Chalk & Wire. We will post updates as they become available.
Posted Sep 03, 2020 - 13:06 EDT
This incident affected: Chalk & Wire.