Investigating Issue
Incident Report for Campus Labs
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 11:02 EDT
Investigating
We are currently investigating an issue with site performance in Chalk & Wire. We will post an update in 30 minutes.
Posted Sep 18, 2020 - 10:59 EDT
This incident affected: Portfolio.