Investigating Issue - Engage Action Center
Incident Report for Campus Labs
Resolved
This incident has been resolved.
Posted 20 days ago. Sep 03, 2019 - 13:20 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 20 days ago. Sep 03, 2019 - 13:00 EDT
Investigating
We are currently investigating an issue with the Action Center in Engage. We will post an update in 30 minutes.
Posted 20 days ago. Sep 03, 2019 - 12:35 EDT
This incident affected: Engage (Action Center web interface).