Investigating Issue - Engage Action Center
Incident Report for Campus Labs
Resolved
This incident has been resolved.
Posted 14 days ago. Sep 09, 2019 - 17:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 14 days ago. Sep 09, 2019 - 15:55 EDT
Investigating
We are currently investigating an issue with the Action Center in Engage. We will post an update in 30 minutes.
Posted 14 days ago. Sep 09, 2019 - 15:51 EDT
This incident affected: Engage (Action Center web interface).