Investigating Issue - Engage
Incident Report for Campus Labs
Resolved
This incident has been resolved.
Posted Sep 18, 2019 - 20:07 EDT
Monitoring
We believe the site performance issues impacting Engage have been addressed. We will continue monitoring and post a final update soon.
Posted Sep 18, 2019 - 16:20 EDT
Investigating
We are currently investigating an issue in Engage. We will post an update once we have more information.
Posted Sep 18, 2019 - 15:49 EDT
This incident affected: Engage (Explore web interface, Action Center web interface, Administration web interface, Forms, Elections, and Registrations, Budgeting web interface, Corq App, Event Check-in App, Public API, Vanity URLs, Mail Relays).